[SOLVED]Getting error in console when entering price and no new calculated price

Home – SaaS Forums Support questions WooPrice Calculator (Pro) [SOLVED]Getting error in console when entering price and no new calculated price

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #5344
    Leslie Wendling
    Participant

    I am getting this error now when someone enters the price that gets calculated:
    [b]POST https://usscinsurance.com/wp-admin/admin-ajax.php?task=price_callback&action=awspricecalculator_ajax_callback&id=47027&simulatorid=2 502
    send @ jquery.js?ver=1.12.4:4
    ajax @ jquery.js?ver=1.12.4:4
    ajaxCalculatePrice @ main.js?ver=4.9.8:292
    calculateProductPrice @ main.js?ver=4.9.8:398
    calculatePrice @ main.js?ver=4.9.8:369
    (anonymous) @ main.js?ver=4.9.8:432
    setTimeout (async)
    (anonymous) @ main.js?ver=4.9.8:431
    dispatch @ jquery.js?ver=1.12.4:3
    r.handle @ jquery.js?ver=1.12.4:3
    main.js?ver=4.9.8:327
    AWS Price Calculator Error:[/b]

    It was working previously and now all of a sudden stopped. We haven’t changed anything. I am using the Pro version and used the excel spreadsheet upload option. It just does a simple percent calculation. I’ve been banging my head trying to troubleshoot it and am out of ideas. The page is at: https://usscinsurance.com/product/select-plan/ If you put in a new number into the sports fee field, the price disappears. Please help!

    #5351
    Naidi
    Participant

    Hi,

    inspecting the request in your site when the user enters a value
    the server return a 502 request , that means in simple words that is not a software problem.
    It may be a problem related to permissions of the files and directories.
    Anyway , can you please try to recreate the calculator from the start and check.
    If the problem persist we will than need more information to resolve the problem and ideally if you
    have a development server so where we can recreate, reproduce and solve the problem.

    Waiting for your feedback.
    Best regards.
    Naidi
    AT 872

    #5350
    Leslie Wendling
    Participant

    Thank you so much for your response.

    Ok, I recreated it from scratch on my dev site and live site and I am now noticing that it works when I am logged in but not when I am logged out. I am sure it isn’t a software problem like you said but knowing that all of this is going on, can you lead me in the right direction? I have a feeling that it has something to do with WPEngine and its permissions or settings but I just don’t know what to tell or ask them. Or what to check on my end. Do you know?

    Thank you for any help you can provide!
    Leslie

    #5349
    Paul
    Participant

    Hello
    You wrote before “It was working previously and now all of a sudden stopped”.
    I have some questions for you:
    – Did you install new plugins, theme,etc?
    – Did you make any update (or automatic update) in your system (plugins, theme, etc)?
    – Did you try disable every plugin and check if the the issue remains?
    – Do you have problems only with our plugin?

    If it’s necessary, we will ask you the credentials to your web site (test website).

    We will be waiting for your feedback.

    Best regards,
    Paul
    AT872

    #5348
    Leslie Wendling
    Participant

    Ok, I disabled all of the plugins and I noticed there was newer version of the pro plugin so I installed it. I re-added the calculators and I am still getting the same ajax error (in the console) when I am logged out. https://usscidev.wpengine.com/product/select-plan/ (this has all of the plugins still disabled except for the calculate price plugin) The price appears for a second and then disappears.
    It works when I am logged in though. I looked around to see the logged in vs logged out and am not finding anything solid to try.

    To answer the rest of your questions, we are not having any issues with any other plugins. We have been trying to remember what we installed or updated before it stopped working but can’t think of anything specific. We tried rolling back the site after it stopped working and it didn’t help.

    I can create you a login if I can send it to you privately if you need that. Just let me know.

    Thank you for helping with this!

    #5347
    Paul
    Participant

    Hello

    Okay, you can send the login here: https://altoswebsolutions.com/contact-us
    We would like an FTP access too.

    We will be waiting for your feedback.

    Best Regards
    Paul
    AT872

    #5346
    Leslie Wendling
    Participant

    Ok, just sent the login info on that form. Thank you!

    #5345
    Paul
    Participant

    Hello

    Thank you. We received your information.

    We will update you as soon as possible.

    Best Regards,
    Paul
    AT872

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.